[Mpi3-ft] MPI_Comm_validate - What's in a name?
jjhursey at open-mpi.org
Wed Jan 25 14:56:19 CST 2012
On the call today it was suggested that we re-evaluate the name
MPI_Comm_validate. It was pointed out that 'validate' seems a bit too close
to 'invalid' which is probably not the semantic that we are trying to imply
with the name. An alternative is 'check', but that is a bit close to
'checkpoint' so might not be the best either. So we are looking for a good
We started a similar discussion for reenable_any_source, which might lend
The semantic behind MPI_Comm_validate [at the moment] are:
(1) A fault tolerant synchronization point returning a consistent value
(failed group) at all participating processes
(2) Allow for the posting of new collective operations on the communicator
(a communicator with potential holes in it)
Name suggestions are welcome.
Postdoctoral Research Associate
Oak Ridge National Laboratory
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the mpiwg-ft