[Mpi-forum] MPI_INFO_GET_ENV naming question
schulzm at llnl.gov
Thu Jul 19 12:25:50 CDT 2012
During the chapter review for Chapter 8, the environment chapter, a question came up at the forum, which we thought requires wider feedback.
Ticket 313 introduced an info object into MPI 3.0 that allows users to query the environment, which is called MPI_INFO_GET_ENV. This name, however, contains a verb and hence follows the naming structure of an MPI function, but is a constant. Hence, should we really go with this name or should we rename this into a name without a verb, like MPI_INFO_ENV, to avoid confusion? People in the room were leaning towards the latter and this is clearly ticket 0 at this point, but we wanted to ask to make sure there is no unintended impact with that change.
Martin Schulz, schulzm at llnl.gov, http://people.llnl.gov/schulzm
CASC @ Lawrence Livermore National Laboratory, Livermore, USA
More information about the mpi-forum