[Mpi-forum] MPI_INFO_GET_ENV naming question

William Gropp wgropp at illinois.edu
Fri Jul 20 11:11:41 CDT 2012

I prefer MPI_INFO_ENV .  Using GET in the name will be confusing.


William Gropp
Director, Parallel Computing Institute
Deputy Director for Research
Institute for Advanced Computing Applications and Technologies
Paul and Cynthia Saylor Professor of Computer Science
University of Illinois Urbana-Champaign

On Jul 19, 2012, at 12:25 PM, Schulz, Martin wrote:

> Hi all,
> During the chapter review for Chapter 8, the environment chapter, a question came up at the forum, which we thought requires wider feedback.
> Ticket 313 introduced an info object into MPI 3.0 that allows users to query the environment, which is called MPI_INFO_GET_ENV. This name, however, contains a verb and hence follows the naming structure of an MPI function, but is a constant. Hence, should we really go with this name or should we rename this into a name without a verb, like MPI_INFO_ENV, to avoid confusion? People in the room were leaning towards the latter and this is clearly ticket 0 at this point, but we wanted to ask to make sure there is no unintended impact with that change.
> Comments?
> Thanks,
> Martin
> ________________________________________________________________________
> Martin Schulz, schulzm at llnl.gov, http://people.llnl.gov/schulzm
> CASC @ Lawrence Livermore National Laboratory, Livermore, USA
> _______________________________________________
> mpi-forum mailing list
> mpi-forum at lists.mpi-forum.org
> http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi-forum

More information about the mpi-forum mailing list