[MPI3 Fortran] MPI function symbol naming convention for tools
steve.lionel at intel.com
Mon Jun 20 13:19:37 CDT 2011
> 3. mpi_recv_f08
> - This function implements (in C or Fortran) MPI_Recv with integer handles and the choice buffer passed via an array descriptor.
> Note that these functions only need to support integer handles because of the way we (thanks to Rolf) have chosen to define the handle types in the mpi_f08 module.
>Please comment on this naming convention.
I would request that any names NOT include text that refers to a specific version of the Fortran standard. The industry already made that mistake once with the .f90 file type meaning "free-form source" - I don't want to see the mistake repeated. Maybe "fdesc" can be used, or something else that has the right connotation without implying some specific standard revision.
Intel Developer Support
More information about the mpiwg-fortran