[Mpi-forum] MPI_Type_create_hvector vs. MPI_Type_hvector

Solt, David George david.solt at hp.com
Fri Jun 25 14:35:51 CDT 2010

I believe the MPI_type_create_* creations were based on routines which should have taken an MPI_Aint.  MPI_Type_hvector was determined to have an argument that should have use an MPI_Aint for stride, by MPI_Type_vector did not.  So only the former was deprecated and replaced.  

I believe the type creation routines change was the only one that left the resulting set of non-deprecated functions with inconsistent naming conventions.   Other routine name changes have occurred (MPI_Keyval_create --> MPI_Comm_keyval_create), but those changes have been applied to all routines of the same form.  (MPI_Keyval_XXXX was changed for all XXXX).   

To cleanup the current state of affairs will likely involve either introducing new routine names which have identical arguments and behaviors as existing ones (ex: MPI_Type_create_vector, which is identical in every way to MPI_Type_vector), or breaking backward compatibility.   I'm all for a clean slate, but it's also hard to argue that when even our own examples use deprecated functions.  I understand the examples fall into some strange "not really part of the standard" category and that using deprecated functions is not incorrect, but it does say something.  

Dave S. 

-----Original Message-----
From: mpi-forum-bounces at lists.mpi-forum.org [mailto:mpi-forum-bounces at lists.mpi-forum.org] On Behalf Of Fab Tillier
Sent: Friday, June 25, 2010 1:22 PM
To: Main MPI Forum mailing list
Subject: [Mpi-forum] MPI_Type_create_hvector vs. MPI_Type_hvector

Some of the MPI type creators were deprecated, such as MPI_Type_hvector, replaced with MPI_Type_create_xxx.  Why weren't others like MPI_Type_vector similarly updated to MPI_Type_create_vector?

Should we clean house a bit and get some consistency in the MPI 3 standard API naming?


mpi-forum mailing list
mpi-forum at lists.mpi-forum.org

More information about the mpi-forum mailing list