[Mpi3-tools] MPI function symbol naming convention for tools
Martin Schulz
schulzm at llnl.gov
Mon Jun 20 22:45:39 CDT 2011
Hi Craig, all,
(I cc-ed the tools group on this as well - this is regarding the
issue how the profiling interface will work with the proposed
new Fortran bindings):
On Jun 20, 2011, at 10:15 AM, Rasmussen, Craig E wrote:
> I've talked with Jeff Squyres and we come up with naming convention that we'd like to propose for tools to have access to Fortran.
>
> I believe we need four different symbol naming conventions. Consider MPI_Recv(), the four functions are
>
> 1. mpi_recv_f
> - This function implements (in C or Fortran) MPI_Recv with integer handles and the choice buffer passed by address.
Does this mean the existing mpi_recv binding will go away?
This would break any existing tool. Can we keep the old naming
scheme for the old interface? Or is this intended as an additional
symbol?
>
> 2. mpi_recv_f_nostatus
> - This function implements (in C or Fortran) MPI_Recv with integer handles without a status variable and the choice buffer passed by address.
Is this just for the new bindings?
>
> 3. mpi_recv_f08
> - This function implements (in C or Fortran) MPI_Recv with integer handles and the choice buffer passed via an array descriptor.
>
> 4. mpi_recv_f_nostatus
> - This function implements (in C or Fortran) MPI_Recv with integer handles without a status variable and the choice buffer passed via an array descriptor.
I assume you mean mpi_recv_f08_nostatus?
>
> Note that these functions only need to support integer handles because of the way we (thanks to Rolf) have chosen to define the handle types in the mpi_f08 module.
>
> Please comment on this naming convention.
Martin
>
> -craig
>
>
>
>
________________________________________________________________________
Martin Schulz, schulzm at llnl.gov, http://people.llnl.gov/schulzm
CASC @ Lawrence Livermore National Laboratory, Livermore, USA
More information about the mpiwg-tools
mailing list