[Mpi-forum] MPI Count proposal from today's meeting

N.M. Maclaren nmm1 at cam.ac.uk
Thu Jun 17 12:30:50 CDT 2010

On Jun 17 2010, Jeff Squyres (jsquyres) wrote:
> So there might be some confusion; I can't tell from your text. The intent 
> is that the mpi spec will only say that sizeof(mpi_count) is >= 
> sizeof(int). An implementation can choose what the real size is. Some may 
> choose to ship 2 libs: one with int and one with a 64 bit integer.

I am happy with that! Just keep ANY reference to "64-bit" from out of the 
specification, because it will cause nothing but trouble. That's from 
bitter experience, incidentally. Suitable wording would be something like:

    MPI_Count is a typedef name for a signed integer type suitable for
    holding vector lengths and offsets.  It shall be at least as large as
    the int type.

Nick Maclaren.

More information about the mpi-forum mailing list